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5.4.8 Lab: Managing System Files with Built-in Utilities in
Windows XP

Introduction
Print and complete this lab.

In this lab, you will use Windows built-in utilities to gather information about the system and to
troubleshoot system resources. You will also learn how to export and import registry setting.

Recommended Equipment
The following equipment is required for this exercise:
» A computer running Windows XP Professional

Step 1
Log on to the computer as an administrator.

Open the command prompt by clicking Start > Run > type cmd > click OK.

Microsoft Windows XP [Uersion 5.1.26801
<G> Copyright 1985-2881 Microsoft Corp.

@ BEE
B

C:\Documents and Settings>John>

What is the drive path shown? Answers may vary.

Type help and press Enter.

& N =1E]
Microsoft Windows KP [Uersion 5.1.26801
(C> Copyright 1?85-2801 Microsoft Corp.

C:“\Documents and Settings>John>help
[For more information on a cific cnmmand type HELP command—-name
RSSOG Displays or modil ile extension associations.
Schedules commands and programs to run on a conputer.
RTTRIB Displays or changes file attributes.
[BREA K Set r clears extended CTRL+C check
g:%kﬁ i ays or mndifies acness control 11 s (ACLs> of files.
D I the name nf or change*‘ the cuuent directory.
ICHCP I r sets the active code page number.
ICHDIR name of or changes the 'ent directory.
k and displays a status po
' mndlfla., the checking of (l1.,k at boot time.
he:
a new 1n..tance of the Windows command interpreter.
default console foreground and bhackground colors.
he contents of two fil or sets of files.

r alters the compression of files on NIFS partitions.
to NTFE§. You cannot convert the

of files and subdirect in a directory.
he contents of two floppy
he content uf one floppy di: to another.
Windows commands. and creates macros.
command ]lnl.ng on or off._
ion nf enu ment changes in a batch file.
one or more fi
Quits the CHD.EXE prog {command interpreter).
Compares two files or sets of Files, and displays the differences
between them.
or a text _‘t11ng in a file or files.
in files.
and for each file in a set of files.
a disk for use with Uindous.
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What is the command to change directory?

What is the command to display the contnets in a directory?

Type cd .. and press Enter.

WINDOWS\system32\cmd.exe

\Documents and SettingssJohn>cd ..

:“\Documents and Settings>
:\Documents and Settings>cd John

:“\Documents and Settings™JohnX>

What is the drive path shown? Answers may vary.

Change back to original drive path.
Example: Type cd John and press Enter.

What is the drive path shown? Answers may vary.

Type dir /? and press Enter.
If asked, Press any key to continue.

C:AWINDOWS\system32\cmd.exe

C:“Documents and Settings~Johnl>dir -7
Displays a st of files and subdirectories in a directory.

DIR [drive:llpathl[filenamel [/ALL:Jattributes1] [#B] [~C]1 [-D]1 L[-L1 L[/N]
[-0LL:1sortorderl] [~P1 [-Q1 [/5]1 [ TLL:]1timefieldl]l [-W]1 L[-X]1 [r4]

[drive: l[pathl[filename]
Specifies drive. directory. andsor files to list.

“A Displays files with specified attributes.
attributes I Directories R Read-only files
H Hidden files A Files ready for archiving
£ System files — Prefix meaning not
Uses bhare format ¢(no heading information or summaryl.
Display the thousand separator in file sizes. This is the
default. Use /—C to disable display of separator.
Same as wide but files are list sorted by column.
Uses lowercase.
Hew long list format where filenames are on the far right.
List by files in sorted ordep.
N By name <(alphabetic)> % By size (smallest first)
E By extension <(alphabetic> D By datestime <(oldest first>
G Group directories first — Prefix to reverse order
Pauses after each screenful of information.
Display the owner of the file.
Displays files in specified directory and all subdirectories.
Controls which time field displayed or used for sorting
timefield 4 CET )]
A Last Access
W Last Written

4 Uses wide list format.

e .3 This displays the short names generated for non—8dot3 file
names. The format is that of ~N with the short name inserted
hefore the long name. If no short name is present, blanks are
displayed in its place.

/4 Displays four—-digit years

Switches may be preset in the DIRCHD environment variabhle. Ouerride
preset switches by prefixing any switch with — c¢hyphen>——for example. /-U.

C:“Documents and Settings“John>

Which switch displays a wide list format?

© 2007-2010, Cisco Systems, Inc. All rights reserved. Page 2



IT Essentials: PC Hardware and Software v4.1 Chapter 5 - Lab/Student

Type dir and press Enter.
Type dir /w and press Enter.

= - o] x|

C: \Documentv and Settlngv\Jnhn)dn
Uolume in ive C is
Volume Serial Humber is F4CS—H421

Divectory of C:“\Documents and Settings“John

07/23-2009 =18 <DIR>
07232009 =18 <DIR>
p?.23,2088 B3:37 PI <DIR> nbi.
092320088 H <DIR> -netheans—registration
102120088 H 314 becker.robots.ini
07.,23-20089 H <DIR> Desktop
02842089 H <DIR> Favorites
B6.84.2PR9 38 P <DIR> My Documents
021020088 H <DIR> RNT
B2./88 .2 088 H <DIR> Start Menu
01.-23-2009 06:31 <DIR> temp
6289 2089 H <DIR> WebEx
i s» 314 bytes
11 Dll(w) 68.156.264,448 bytes

C:\Documents and Settings\Johnldir ~u
Volume in drive C is BootDisk
Uolume Serial Humber is F4C8-A421

Directory of C:\Documents and Settings\John

[.1 -1 [.nbil
[.netheans—registration] heckel robots.ini [Desktopl
[Favorites] [My Documents] [RNT 1
[Start Menul [templ [WebEx]

1 Fileds> 314 bytes

11 Dir{s> 68,156.264.448 bytes

C:\Documents and Settings“John>

What is the difference between these two commands?

Type VOL.
What volume is drive C in? Answers may vary.

Close the Command prompt window.

Step 2
Open System Information by clicking Start > Run > type msinfo32 > click OK.

Click the plus sign next to Hardware Resources, Components, and Software
Environment. Expand the window so you can see all the content.

[ (o] [Ofx]

Frd et | [ Chosa et
Samch velecied cosgory only [ Samch categon names any
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Under the System Summary heading locate and list the following:
Processor

BIOS Version/Date

Total Physical Memory

Under the Hardware Resources heading locate and list the following:

DMA channels and the device using the resources.

I/O address range for these devices.
Printer Port (LPT1)
Communications Port (COM1)
Communications Port (COM2)

IRQ address for these devices.
System timer

Communications Port (COM1)
Communications Port (COM2)

Under the Components heading and Software heading look around to see what
information is provided in these areas.

Close the System Information window.

Step 3
Open System Configuration Utility by clicking Start > Run > type msconfig > click OK.
Note: It is very important that you do not make any changes in this utility without
instructor permission.

=% System Configuration Utility

General L SYSTEM,INI || WINLINI | BOOT. INI || Services | Starkup
Startup Selection
(%) Mormal Startup - load all device drivers and services
() Diagnastic Startup - laad basic devices and services only

() Selective Startup

[ Launch System Restore ] ’ Expand File... ]

[ K H Cancel ][ Apply H Help ]

Click the General tab if not all ready active.
What are the startup options?
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Click the SYSTEM.INI, WIN.INI and BOOT.INI tabs. These tab are for modifying these

files.

Click the Service tab. This tab lists the computers services and there status.

% System Configuration Utility

General | SYSTEM.IMI | WIN.IMI | BOOT.INI | Services | Startup

Service Essential | Manufacturer Status A

Application Micr Co Running

Application Management Stopped

ASP.MET State Service Micrasoft Corporation Stopped

Ati Hotkey Poller ATI Technologies Inc, Running

Windows Audio Microsoft Corporation Running

Background Inteligent T... Microsoft Corporation Stopped

Computer Browser Microsoft Corporation Running

Indexing Service Microsoft Corporation Stopped

.MET Runtime Optimizati. .. Microsoft Corporation Stopped

COM+ System Application Microsoft Corporation Stopped

Cryptographic Services Microsoft Corporation Running

F‘ DCOM Server Process La... Yes Microsoft Corporation Runnina ¥
[Hide All Microsoft Services

[ K ] [ Cancel ] [ Apply ] [ Help

]

Can you enable and disable services at this tab?

Click the Startup tab. This tab lists the programs that are automatically loaded every time
you turn on your computer.

Click Cancel to close the System Configuration Utility window.

Step 4

Open DirectX Diagnostic Tool by clicking Start > Run > type dxdiag > click OK.
If you are asked to have DirectX check driver signatures click No.

Note: When DirectX Diagnostic Tool first opens it may take a minute to load all
information. Your DirectX Diagnostic Tool may not appear exactly as shown in this lab.

BaEE

System iDlrecD< Files | Display 1| Displap 2 | Sound

Music | Input | Metwark | Mare Help

This tool reports detailed information about the Direct components and drivers installed on your system, It lets you test functionality,
diagnose problems, and change your system configuration to work best.,

IF you know what area is causing the problem, dick the appropriate kab above. Otherwise, you can use the "Mext Page” button below to
wvisit each page in sequence.
The "Mare Help” page lists same other taols that may help with the problem you are experiencing.

System Information

Current Dake/Time! Friday, July 24, 2009, 07:41:57
JOHN-DESKTOP

Micrasoft Windows XP Professional (5.1, Build 2600)
English {Regional Setting: English)

To Be Filled By ©.E.M,

To Be Filled By O.E.M,

BIOS Date: 09/01/04 23:23:09 Yer: 08.00.09
Intel(R) Pentiur(R) 4 CPLI 3.00GHz (2 CPLS)
2048ME RAM

609MB used, 3334MB available

Directs 9.0c (4.09,0000.0004)

Computer Mame:
Operating System:
Language:

System ManuFacturer:
System Model:

BIOS:

Processor:

Memary:

Page file:

Directs Version:

[ check for wHGL digital signatures

DxDiag 5.03.2600,2160 Unicode Copyright @ 1998-2003 Microsoft Corporation. Al rights reserved.

[ Mext Page H Save &ll Information... ] l Exit
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Make sure the System tab is active.
What does this tool report?

Click Next Page until you are at the DirectX Files tab.
A list of DirectX files is listed.

Click Next Page until you are at the Display tab.
Click Test DirectDraw.

¥ DirectX Diagnostic Tool

System | Direct< Files | Displap 1 | Display 2 | Sound || Music | Input | Netwark | More Help|

Directs Features

Device Drrivers
Mame: RADEON 9800 PRO IMain Driver: atizdvag.dll
Manufacturer: ATI Technologies Inc. Wersion: 6,14.0010.6601 {English)
Chip Type: RADEON 9500 PRO AGP (Dx4E48) Date: 2/21/2006 2114645
DAC Type: Internal DAC(400MHZ) WHQL Logo'd: nfa
Approx, Tokal Memory: 128.0 MB Mini YDD: ati2mtag,sys
Current Display Mode: 1600 x 1200 {32 bit) (60Hz) WDD: nfa
Monitor: Plug and Play Monitor DOI Yersion: 9 {or higher)

Motes

DirectDraw Acceleration:  Enabled Test DirectDraw [:
Direct3D Acceleration:  Enabled [ Test Direct3D ]
AGP Texture Acceleration:  Enabled

Mo problems Found.
To test DirectDraw functionality, click the "Test DirectDraw" button above,
To test Direct3D Functionality, click the "Test Direct30" button above,

[

Mext Page ] [ Save Al Information... ] [

Exit

Follow the rest of the instruction as the test progresses.

Place a check mark next to ever test that your computer passes.
alternating black and white rectangles
bouncing white box in a black box
fullscreen bouncing white box

Click Test Direct3D.

Follow the rest of the instruction as the test progresses.
DirectX 7 interface test: what did you see? S

DirectX 8 interface test: what did you see?

DirectX 9 interface test: what did you see?
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Click Next Page until you are at the Sound tab.
If you have a headphones click Test DirextSound. If you have no headphones move to

the next instruction.

¥/ DirectX Diagnostic Tool

EVS}'S[EITI | Direct Files | Dispiay 4] | Di;p\ay 2| Sound |’i~d’|.|s’\c’f’|npul " I Netwark | More gelp

Dievice

Directy Features

Full acceleration
Hardware Sound
Acceleration Level:

Nates

Test DirectSound

Drivers
Mame: SoundMAX Digital Audio Mame: smwdm.sys
Device ID: PCIWEN_B086DEY_24055UB5YS_B0F31043REY_0 Wersion: 5,12,0001,3630 (English)
Manufacturer ID: 1 Date: 6/2(2003 14:42:14
Product 1D: 100 WHOL Logo'd: nja
Type: WDM Cther Files:
Default Device: Yes Provider: Analog Devices

+ Mo problems Found,

+  Totest DirectSound Functionality, dick the "Test DirectSound” button above,

[

Mext Page

l [ Save All Information... ] [

Exit

Did you hear the sound effects in the audio test?

Click Next Page until you are at the Music tab.
If you have a headphones click Test DirextMusic. If you have no headphones move to

the next instruction.

!-g_\.Jstem | "[il-recL;Z.F-\I;as !:.Ii)ulsp-la.ny 'I- II Ii)l-spla.:p 2|Sound| Music ‘"\nput ’ II -I:Jetwnll; | -id-ole }:i-a\p

General MIDT DLS Collection:

CHAWINDOWS|SYSTEM32  driversiGM, DLS (Version 1,00,0016,0002)

IMusic Ports
Description Type Kernel Mode  InfOut Supports DLS | External  Default Port
Microsoft Synthesizer Software Mo Oukput Wes Mo Yas
SoundrMax Digital Audio Software Yes  Oukput Wes Mo Mo
Microsoft MIDI Mapper [Emulated] Hardware Mo Qubput MNo MNo Mo
SoundMAX WDM MIDI [Emulated] Hardware Mo Oukput Mo MNo Mo
Microsaft G5 Wavetable SW Synth [Emulated] Hardware Mo Output Mo Mo Mo

Directy Features

Default Port Acceleration: Mok Available

Disable

[
SoundMax Digital Audio

Wicrasoft MIDI Mapper [Emulated]
SoundMax WM MIDI [Emulated]

Test using this port:

[ESR S

Motes

Test DirectMusic k

+  DirectMusic test results: All tests were successful,

|

Mext Page ] I Save All Information. .. I [

Exit

Did you hear music playing?
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Click Next Page until you are on the Input tab.
What information is listed on this page?

Click Next Page until you are on the Network tab.
What information is listed on this page?

Click Next Page until you are on the More Help tab.

Click on the various buttons to see what is provided.
What tools are provided on this page?

Click Exit.

Step 5
Open the Desktop tab in Display Properties by right clicking the desktop > Properties >
Desktop tab.

What is the Background picture?
Answers will vary

Set the background image to (None). If the Color dropdown button is not blue, click the
Color dropdown button, select blue.
Click OK.

Themes | Desktop | Screen Saver | Appearance | Settings

Background:

.ﬂ Azcent

,ﬂ Auturit

.ﬂ Azul

[ Bliss

.ﬂ Blue Lace 1 Calar:

- | (]
PSS ]
Customize Desktop..

’ (] ” Cancel H Apply ]

The computer screen should now have a blue background. If not ask the instructor for
assistance.
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Step 6

Open Registry Editor by clicking Start > Run > type regedit > click OK.
Note: Do make any changes in the Registry Editor without instructor permission.

% Registry Editor

File Edit WYiew Favorites Help

=
#)-(_] HKEY_CLASSES_ROOT
({2 HKEY_CURRENT _USER
(-2 HKEY_LOCAL_MACHINE
[#-[Z] HKEY_USERS

[#-[Z HKEY_CURRENT_COMFIG

Mame

|~

Type

Data

| %

My Cornputer

Click the HKEY_Current_User icon. To search for the desktop Background key click
Edit > Find > type Background > click Find Next.

- [BX]

= My Comnputer
(-2 HKEY_CLASSES_ROOT
[#-423 HKEY_CURRENT_USER,
(-2 HKEY_LOCAL_MACHINE
[0 HKEY_USERS
[#-(Z HKEY_CURRENT_CONFIG

Marme

[ab]¢pefauit)

Type
REG_SZ

Data

{walue not set)

Find what:

| [ Find Nex

Look. at
Keys
Walues
Drata

[ Match whale string only

Cancel

|

My ComputeriHKEY_CURRENT_LISER

The Background value is located. Leave this window open.

% Registry Editor

File Edit Wiew Favorites Help

HELEEX

| My Computer
[Z0 HKEY_CLASSES_ROOT
[Z1 HKEY_CURRENT_USER
D AppEwvents
{11 Console
BD Cantral Panel
D Accessibility
(] Appearance
29 Colors
(23 Current
- D Cursors
(22 Custom Calors
(21 Desktop
77 don't load

<

E

|5

|

Marne
[ab](Defaulty
ActiveBorder
[ab] activeTitle
AppWorkSpace
[ab]

g
ButtonAIternateFace
ButtonDkShadow
ButtonFace
[aB]ButtanHilight
[ab]ButkanLight
ButtonShadow
E"‘]ButtonText

Tvpe
REG_ST
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG_SZ
REG 52

Data
{walue not set)
212 208 200
084 227
125128 125
075152
151 151 181
113111 100
236233216
255 255 255
241 239 226
172 168 153
oo

1>

|

My Computeri\HKEY _CURREMT _IUSER\Control PaneliColors

In which folder is the Background located?
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What is the data value of the Background (hint — it has three number that corresponds to
red, green blue)? Answers may vary based on the shade of red selected in Display
Properties.

Step 7
We will now export HKEY_CURRENT_USER\Control Panel\Colors folder.
In the left pan click the Colors folder.
Click File > Export. Save the file to the Desktop. File name: BlueBKG

At the desktop right click the BlueBKG.reg icon > Edit.

[ BlueBKG.reg - Notepad E] g@l@l

File Edit Format View Help

pindows Registry Editor version 5.00 ~

[HEEY_CURRENT_USERNCoOnTraol Panel™Colors]
"activeBorder="212 208 200"
"ActiveTitle"="0 84 227"
"appworkspace"="128 128 128"
"Background"="0 78 152"
"ButtonalternateFace”="181 181 181"
"Buttonbkshadow"="113 111 100"
"ButtonFace"="236 233 216"
"ButtonHilight"="255 255 255"
"ButtonLight"="241 239 228"
"Buttonshadow'="172 168 153"
"ButtonText"="0 0 0"
"GradientactiveTitle"="61 149 255"
"gradientInactiveTitle"="157 185 235"
"GrayText"="172 168 153"
"Hilight"="4% 106 197"
"HilightText"="255 255 255"
"HotTrackingcolor"="0 0 128"
"InactiveBorder"="212 208 200"
"ThactiveTitle"="122 150 223"
"InactiveTitleText"="216 228 248"
"InfoText"="0 0 0"
"Infowindow'="255 255 225"
"Menu'="255 255 255"

"MenuText"="0 0 0"
"scrollbar="212 208 200"
"TitleText"="255 255 255"
"wincow'="255 255 255"
"windowFrame"="0 0 0"
"windowText"="0 0 0"
"MmenuHilight"="49 106 197"
"Menugar'="2346 233 21&"

What is the data value of the Background? Answers may vary based on the shade of
blue selected in Display Properties.

Close BlueBKG.reg — Notepad window.

Step 8
Open the Desktop tab in Display Properties by right clicking the desktop > Properties >
Desktop tab.
Set the Color dropdown button is not red, click the Color dropdown button, select red.
Click OK.

In a few second the desktop will turn to red.

© 2007-2010, Cisco Systems, Inc. All rights reserved. Page 10



IT Essentials: PC Hardware and Software v4.1

Chapter 5 - Lab/Student

Click the Registry Editor window so it is activated.
On your keyboard press F5 to refresh the Registry Editor window.

% Registry Editor

File Edit Yiew Favorites Help
} My Computer Al Mame Type Data ~
(1 HKEY_cLASSES_ROOT (Default) REG_5Z {walue not set)
(3 HKEY_CURRENT_USER [ab]activeBorder REG 52 212 208 200
(0 AppEvents [aB) activeTite REG_SZ 084 227
o g Esxroohlapanel || [BB]appwaorkspace REG_SZ 128 125 128 =
(1 Accessiility chground REG_SZ 25500
D Appearance ButtonnlternateFace REG_5Z 181 181 181
5 Colors [ab]ButtonDkshadaw REG_SZ 113 111 100
(3 Current [ab]ButtonFace REG_SZ 236 233 216
(3 Cursors [ab]ButtanHilight REG_SZ 255 255 255
(23 Custom Calars [ab]ButtonLight REG_SZ 241 239 226
{23 Desktop ButtonShadow REG_3Z 172 1658 153
77 dan't load ¥ | [ABlButtanText REG 52 000 s
< > & >
My ComputeriHKEY _CURRENT _USER\Control PaneliColors

What is the data value of the Background? Answers may vary based on the shade of red
selected in Display Properties.

Step 9

We will now import BlueBKG.reqg file.
Click the Registry Editor window so it is activated.

Click File > Import. Locate and click the BlueBKG.reg icon then click Open. Click OK.

%" Registry Editor

File Edit View Favorites Help
| My Computer 4} MName Type Data ,:
% HKEY_CLASSES_ROOT (28] Defaul) REG.52 oalo (g Sae)
EEV*CURRENT*USER [a¥] activeRorder REG_SZ 212 208 200
& EppEvlents ActiveTitle REG_SZ 084 227
=@ Contr pane (28] appiorkspace REG_5Z 128 128 128 L
(23 Accessibilicy ckground REG_5Z 075152
B Arnesiaice [ab]ButtonalternateFace REG_SZ 181 181 181
23 Calars [ab]ButtonDkshadaw REG_SZ 113 111 100
23 current [28]ButtanFace REG_SZ 236 233216
23 cursors ButtnnHiIight REG_SZ 255 255 255
(23 <ustom Colors [aB]ButtanLight RES_SZ 241 239 226
(21 Deskkop ButtonShadow REG_SZ 172 168 153
7 don't laad ¥ | [ablButtonText REG SZ 0oo .
S |* £ »
Iy ComputeriHKEY_CURREMT_USERYControl PanellColors

Click the Registry Editor window so it is activated.
What is the data value of the Background? Answers may vary based on the shade of
blue selected in Display Properties.

What is the color of the desktop?

Restart the computer.
What is the color of the desktop?

Reset Display Properties Background to the original settings (hint — see step 5).
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